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AutoSD Steel Detailing 

Setup 
 

This file is in your C:\autosd folder. The file name is AutoSD_Setup.htm 

 

 

Copyright 1990 – 2021 by AutoSD, Inc. 

 

This publication, or parts thereof, may not be reproduced in any form, by any means, for any 

purpose. 

 

AutoSD, Inc. makes no warranty, expressed or implied, including but not limited to any implied 

warranties of merchantability or fitness for a particular purpose, regarding these materials and 

makes such materials available solely on an "as-is" basis.  

 

In no event shall AutoSD, Inc. be liable to anyone for special, collateral, incidental, or 

consequential damages in connection with or arising out of the use of these materials. It is the 

user's sole responsibility to check and verify the validity of the information obtained from these 

materials. 

 

AutoSD, Inc. reserves the right to revise and improve their products as they see fit. This 

publication describes the state of this product at the time of its publication and may always not 

reflect the product in the future. 

 

 

AutoSD Steel Detailing version 2021 is compatible with AutoCAD 2000 – 2022 and Bricscad 

Pro/Platinum 13 - 20 

 

 

Minimum screen resolution for displaying dialog boxes is 1280 x 960 

 

 

 

 

 

 

Trademarks 

 

AutoCAD is a registered trademark of Autodesk, Inc. 

BricsCAD is a registered trademark of Bricsys NV. 

WINDOWS is a registered trademark of Microsoft Corporation. 

CVSpro is a registered trademark of CadVantage, Inc. 
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Configure AutoCAD or BricsCAD. 

Start AutoCAD or BricsCAD.  

 

AutoCAD Release 2000 - 2013 configuration 

From the pulldown menu select TOOLS and then Options or type CONFIG and press enter. A 

dialog box is displayed. 

 

Select Files 

Double click on Support file search path. 

Select Add.  Add the following line in the newly created box. 

  C:\AUTOSD\SUPPORT 

   Where: 

   C:  is the drive where AutoSD is installed. 

   AUTOSD  is the name you gave for the AutoSD folder. 

Pick the “Apply“ button. 

 

AutoCAD Release 2014 and later configuration 

From the pulldown menu select TOOLS and then Options or type CONFIG and press enter. A 

dialog box is displayed. 

 

Select the Files tab 

Double click on “Support file search path” or pick the plus sign next to it. 

Select “Add” and add the following line in the newly created box. 

  C:\AUTOSD\SUPPORT 

   Where: 

   C:  is the drive where AutoSD is installed. 

   AUTOSD  is the name you gave for the AutoSD folder. 

Pick the “Apply“ button. 

 

You can add the following to your Trusted Locations to avoid constant warnings about loading 

files or you can disable the warning feature. 

 

To disable the warning feature instead of adding paths to “Trusted Locations” close the dialog 

box and type SECURELOAD at the command and press enter. Type 0 (zero) and press enter. 

 

To add folders to “Trusted Locations”: 

 

For AutoCAD LT:  

Close the current dialog box. From the pulldown menu select CADSTA > CADSTA Tools > 

TrustedPaths Manager. 

 

Full version of AutoCAD: 

Double click on “Trusted Locations” or pick the plus sign next to it. 
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Repeat the following steps for each folder below. If you did not purchase the complete AutoSD 

Steel Detailing program, some folders will not exist, and AutoCAD will warn you of this. In 

those cases, do not include that folder. 

Pick the “ADD” button and enter the following line in the newly created box or, to avoid 

typographical errors, pick the Browse button and select the folder. 

 

C:\AUTOSD    C:\AUTOSD\BM 

C:\AUTOSD\BONUS   C:\AUTOSD\BRACE 

C:\AUTOSD\CNC   C:\AUTOSD\COLUMN 

C:\AUTOSD\DATA   C:\AUTOSD\DATA\BACKUP 

C:\AUTOSD\HIP_VAL  C:\AUTOSD\LADDER 

C:\AUTOSD\MENUS  C:\AUTOSD\RAILS 

C:\AUTOSD\STAIR   C:\AUTOSD\SUPPORT 

C:\AUTOSD\WELDS 

 

Pick the “Apply“ button. 

Close the dialog box by picking OK. 

 

BricsCAD Pro/Platinum 13 and later configuration 

Type CONFIG and press enter or pick Settings > Settings. A dialog box is displayed. 

 

Expand Program options 

Expand Files 

Select Support File Search path 

Pick the button at the right end of the line with the three dots... 

Double click on the blank line at the bottom of the Folder List and then pick the button at the 

right end of the line with the three dots...   

Expand My Computer 

Expand Local Disk (C:) 

Expand AutoSD 

Select Support 

Pick OK 

Pick OK again 

 

Expand Templates 

Select Template 

Pick the button at the right end of the line with the three dots... 

Change folders to C:\autosd\support and select Autosd.dwt 

Pick Open 

 

Select Template path 

Pick the button at the right end of the line with the three dots... 

Change folders to C:\autosd\support 

Pick OK 
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Loading the menu 

 

At the command prompt type MENULOAD or CUILOAD and press enter. 

Select AUTOSD from the “Loaded Customization groups” and pick Unload. (Existing users) 

Pick Browse. (BricsCAD: Pick button with three dots …) 

In the (AutoCAD: “Load/Unload Customization”) (BricsCAD: “Choose a Customization File”) 

box pick the arrow at the right end of the “Look in” box and select the drive where AutoSD is 

installed. In the large box, double click on AUTOSD, double click on MENUS. 

AutoCAD 2000 – 2002:  select autosd02.mnu 

AutoCAD 2004 – 2009:  select autosd.mnu (see Note below). 

AutoCAD 2010 – 2014:  select autosd.cuix 

AutoCAD 2015 and later:  select autosd15.cuix 

BricsCAD 19 and older:  select autosd.cuix   

BricsCAD 20 and later:  select autosd.cuix if you are using the light theme and autosd15.cuix 

if you are using the dark theme. 

BricsCAD: An *.CUI file will be created from the *.CUIX file for Bricscad. Pick the *.CUI file 

if you need to load the menu file again unless you need to overwrite the CUI file with an update 

to AutoSD. 

Pick Load   If a message box appears when loading autosd.mnu  

  warning that loading of a template file overwrites the  

   menu source file.  Pick YES to continue loading the 

menu file. 

 

For AutoCAD 2000 - 2005: 

Select AUTOSD from “Menu Groups” and pick the Menu Bar tab. 

Select where you want to place the AutoSD menu group in the Menu Bar list and pick Insert. 

Select Close 

 

Note. 

All versions of AutoCAD and BricsCAD can load the autosd.mnu file. You may need to change 

“Files of type” to “Legacy menu files (*.mnu)” at the bottom of the “Select Customization File” 

dialog box to be able to select the AUTOSD.MNU file. The MNU file does not have the ribbon 

menu in it. 

 

If you get “smiley faces” in your toolbars and have an older version of AutoCAD, you need to 

do the following: 

1. Add C:\autosd\icons to the “Support file search path” 

2. Unload the autosd menu 

3. Load autosd02.mnu from c:\autosd\menus 

 

If you have BricsCAD 15 or AutoCAD 2010 or later and load the AUTOSD.CUIX menu file 

you can use the ribbon menu in AutoSD. The RIBBON command turns the ribbon menu on. 

The RIBBONCLOSE command turns the ribbon menu off. The ribbon menu can be used with 

or without the pulldown and toolbar menus. Pulldown menus can be turned on and off with the 

command MENUBAR. Set the value to 1 to turn it on and to 0 to turn it off. 
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Uninstalling AutoSD. 

 

Open the Control Panel and pick Uninstall programs. Scroll down the list of programs until you 

find AutoSD Steel Detailing 2020. Select it and pick uninstall. 

 

Useful commands 

 

RIBBON Turns ribbon menu on 

RIBBONCLOSE Turns ribbon menu off 

MENUBAR 1, turns menubar on. 0, turns menubar off 

-TOOLBAR Enter toolbar name or [ALL]: Turns on named toolbar. 

MENULOAD Opens the dialog box to load the AutoSD menu. 

OPTIONS Opens the Options dialog box to add support file search path. 

 

 

AutoSD reference manual 

The AutoSD reference manual is in your C:\autosd folder. The file name is 

AutosdRefmanual.pdf. It is accessible by picking Help from the AutoSD pulldown menu or by 

picking the question mark in the Shop bill panel under AutoSD I of the Ribbon menu. If you 

would like a printed copy you may print the pdf file or order a copy from AutoSD, Inc. 

 

 

Configure AutoSD. 

 

After configuring AutoCAD and loading the AutoSD menu, select the AutoSD pulldown menu 

and Customer Configuration. Select Detail variables. Select Unnamed and pick Edit. Change the 

settings in the dialog boxes as needed and select OK. Select Color list. Select AutoSD from the 

list of names and pick Edit. Use the dialog box to set each color by picking on the color of the 

item to be changed. Colors for weld symbols are set in the Weld Menu dialog box. Pick OK to 

close the Setting Colors dialog box. You can rename the file names and add more configurations 

if needed. Pick OK again to exit the configuration. 

 

 

Starting AutoSD. 

 

Start AutoCAD or BricsCAD. If you are using AutoCAD LT, you need to use CADSTA 

desktop icon to start AutoCAD LT. 

 

Select File > NEW. Select "Use a Template" and select the autosd.dwt template from your 

C:\autosd\support folder. 

Pick AutoSD > Format > SETUP or AutoSD I > Utilities > SETUP if you are using the ribbon 

menu. 
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Select AutoSD for Detail Variables, Unnamed - 24x36 for Shop bill, None for Material list and  

AutoSD for Color for the four configurations and pick OK. 

In the Setup box, accept the defaults which are: Architect for Unit type 1 = 1’ for Drawing scale, 

D - 24 x 36 for drawing size, horizontal for paper size and AutoSD. 

Pick OK and the drawing is created. 

Pick File > Save and save the drawing. 

You can start detailing now. 

 

A folder called C:\AUTOSD\CUSTOMER is created by the installation program. Where C: is 

the drive you installed AutoSD on and AUTOSD is the name of the folder you chose to install 

AutoSD in. You can use the shop bill drawings in this folder, (24x36BOM.dwg and 

11x17BOM.dwg), to create your own shop bill. Open the drawing, change the name in the title 

box, save and close the drawing. 

 

FT.IISS or II.SS 

You will see this in most of the input prompts. It is the standard method of entering dimensions. 

If the current dimensional unit format is set to architectural the FT.IISS format will be used. If it 

is set to fractional the II.SS format will be used. 

 

Where: 

FT = number of feet 

II = number of inches 

SS = number of sixteenths 

 

Using the FT.IISS format:      Using the II.SS format:  

1'- 3 1/2" would be entered as 1.0308   15 1/2" would be entered as 15.08 

6'- 10 15/16" would be entered as 6.1015   82 15/16" would be entered as 82.15 

4'-0" would be entered as 4     48” would be entered as 48 

3 1/2" would be entered as .0308    1/2" would be entered as .08 

 

This manual uses the FT.IISS format in the examples. 

 

POSITIVE AND NEGATIVE    

Many programs provide you with slide drawings or images in dialog boxes for user input. 

Positive input will go in the direction shown in the slide; negative input will go in the opposite 

direction from that shown in the slide 

 

FT-II*SS 

You will see this in most of the input prompts when you set up a drawing for CVSpro.  It is the 

standard method of entering dimensions for CVSpro. If the current dimensional unit format is 

set to architectural the FT-II*SS format will be used. 

 

Where: 

FT = feet II = inches SS = sixteenths 
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Using the FT-II*SS format:  

1’- 3 1/2" would be entered as 1-3*12 

6’- 10 15/16" would be entered as 6-10*15 

4'-0" would be entered as 4- 

5 1/2" would be entered as 5*12 

3" would be entered as 3 

1/2" would be entered as *12 

 

Feet are entered followed by a minus sign.  2’-0  = 2- 

Inches are entered as a whole number.  3”  = 3 

Fractions are entered preceded by an asterisk.  1/2”  = *12 

Fractions are as follows: 

1/16  = *1 5/16  = *5 9/16 = *9 13/16 = *13 

1/8  = *18 3/8  = *38 5/8  = *58 7/8  = *78 

3/16 = *3 7/16  = *7 11/16  = *11 15/16  = *15 

1/4 = *14 1/2 = *12 3/4 = *34 
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